Musik on Hold Asterisk 11.0.1

Konfigurationsdiskussionen bei Asterisk direkt

Moderatoren: rainer, Tim

Antworten
chonta
Anfänger
Beiträge: 5
Registriert: Mi 14. Nov 2012, 15:22

Musik on Hold Asterisk 11.0.1

Beitrag von chonta » Di 20. Nov 2012, 13:05

Hallo,

folgendes Problem.
Es wurden Queues angelegt und eine selbst definierter Musik on Hold Eintrag zugewiesen.
In der musikonhold.conf wurde auch der Pfad richtig und absolut ingetragen.
Das Problem wird jemand auf halten gestellt wird einfach die musik aus von default (moh) abgespielt.
Wird dieser Pfad geändert wird die dort einhaltene Musik abgespielt.

Warum macht asterisk das? Die Queue sagt doch ich will Musik x verwenden und nicht default und die Musik kann auch abgespielt werden (default Pfad auf die Gewünschte Musik gelegt)
Wenn ich default auskomentiere, kommt wieder das defaultgeklimper.

Gruß

Chonta

Benutzeravatar
Tim
Administrator
Beiträge: 155
Registriert: Sa 1. Nov 2008, 00:02
Wohnort: Freilassing / Oberbayern / Deutschland
Kontaktdaten:

Re: Musik on Hold Asterisk 11.0.1

Beitrag von Tim » Mi 21. Nov 2012, 10:51

Kommt wenn man die Queue anruft auf das Default-Geklimper? Oder passiert das nur, wenn jemand von einem Gespräch aus auf Hold gelegt wurde?

Wenn es nur von einem Gespräch aus passiert, dann müsste im Dialplan die passende MOH-Klasse gesetzt werden.

Gruß
Tim
Dipl.-Ing. Tim Grünberg
dCAP zertifiziert seit 2007

Debian Wheezy x86_64
Asterisk 13.5.0 mit JNET-DAHDI 1.0.14
Junghanns QuardBRI, TDM400P
SNOM 370, SNOM M3 & Grandstream GXP2000

AMD Athlon II X4 605e -- 10 GB DDR3 RAM -- 2 TB SATA2 HDD Space

chonta
Anfänger
Beiträge: 5
Registriert: Mi 14. Nov 2012, 15:22

Re: Musik on Hold Asterisk 11.0.1

Beitrag von chonta » Fr 30. Nov 2012, 11:26

Hallo,

es passierte immer. Egal wie es wurde immer das Default verwendet.
Aber das Problem ist im Moment gelößt. Ich habe eine Asterisk 11.0.1 ohne Digium GUI und die hat das Problem nicht.

Gruß

Chonta

Benutzeravatar
Tim
Administrator
Beiträge: 155
Registriert: Sa 1. Nov 2008, 00:02
Wohnort: Freilassing / Oberbayern / Deutschland
Kontaktdaten:

Re: Musik on Hold Asterisk 11.0.1

Beitrag von Tim » Sa 1. Dez 2012, 16:28

Dann scheint das Problem bei der GUI zu liegen. Der Asterisk ist ja trotzdem der gleiche.
Dipl.-Ing. Tim Grünberg
dCAP zertifiziert seit 2007

Debian Wheezy x86_64
Asterisk 13.5.0 mit JNET-DAHDI 1.0.14
Junghanns QuardBRI, TDM400P
SNOM 370, SNOM M3 & Grandstream GXP2000

AMD Athlon II X4 605e -- 10 GB DDR3 RAM -- 2 TB SATA2 HDD Space

Antworten