Weiterleitung Festnetz auf Festnetz, Asterisk legt auf

Konfigurationsdiskussionen bei Asterisk direkt

Moderatoren: rainer, Tim

Antworten
derbenni
Anfänger
Beiträge: 1
Registriert: Di 11. Dez 2012, 15:28

Weiterleitung Festnetz auf Festnetz, Asterisk legt auf

Beitrag von derbenni » Di 11. Dez 2012, 15:49

Hallo zusammen,

ich habe ein Problem bei der Umleitung einer Festnetznummer auf eine andere Festnetznummer.

Ich muss dazu sagen, ich bin blutiger Anfänger, habe mich heute zum ersten mal mit dem gesamten Thema Asterisk auseinandergesetzt. Wenn ich also irgendwelche dummen Fehler mache, seid bitte nachsichtig :)

Zunächst das Szenario:

Ich habe eine Festnetznummer (004912345) bei SIP Gate. Die Asterisk ist auf diese Nummer registriert. Eingehende Anrufe auf diese Festnetznummer kommen auch in der Asterisk an, ich kann mir z.B. ein "Hello World" vorspielen lassen oder einen Echo-Test machen.

Ziel ist es, dieses eingehende Gespräch, wiederum über einen SIP-Provider, auf ein anderes Festnetz (004967890) umzuleiten.

Der Dialingplan sieht bisher so aus:

Code: Alles auswählen

[sipgatein]
exten => SIPGATE,1,Dial(SIP/andererVOIPProvider/004967890,,r)
exten => SIPGATE,n,Hangup()
Das Problem ist, dass bei einem eingehenden Anruf auf 004912345 zwar ein Call an 004967890 rausgeht, sobald der Angerufene aber das Telefon abhebt, wird die Verbindung zum Angerufenen sofort getrennt. Die Verbindung zum Anrufer bleibt bestehen bis dieser auflegt.

Die Verbindung scheint genau in dem Moment getrennt zu werden, in dem die beiden Verbindungen zusammen gechannelt werden sollen.

Diese Vermutung hat sich noch verstärkt als ich folgendes versucht habe:

Code: Alles auswählen

[sipgatein]
exten => SIPGATE,1,Dial(SIP/andererVOIPProvider/004967890,,rA(hello-world))
exten => SIPGATE,n,Hangup()
In diesem Fall wird die Verbindung aufgebaut, sobald der Angerufene abnimmt wird ihm "Hello World" vorgespielt und erst danach wird aufgelegt (wieder nur beim Angerufenen, nicht beim Anrufer).

Ich habe schon sehr viel ausprobiert, finde aber keine Lösung.

Kann mir evtl. jemand dieses Verhalten erklären oder kennt dieses Phänomen?

Danke und Gruß, Benni

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: Weiterleitung Festnetz auf Festnetz, Asterisk legt auf

Beitrag von rainer » Mi 12. Dez 2012, 07:42

Guten Morgen Benni,

das klingt nach einem NAT-Problem ...

Wenn dein Asterisk "hinter" einem Router steht, sendet er zu deinem Provider die IP aus deinem Netzwerk (z.B. 192.168.x.x).

Zu dieser IP kann kein RTP aufgebaut werden.

Die neueren Asterisk Versionen haben die Config-Datei res_stun_monitor.conf ...

Da muss folgendes rein:

Code: Alles auswählen

[general]
stunaddr = stun.sipgate.net:10000
stunrefresh = 30
Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

Antworten