Keine ISDN incoming Calls

Konfigurationsdiskussionen bei Asterisk direkt

Moderatoren: rainer, Tim

Antworten
hkl
Anfänger
Beiträge: 2
Registriert: Di 19. Feb 2013, 08:52

Keine ISDN incoming Calls

Beitrag von hkl » Di 19. Feb 2013, 09:25

Hallo,

ich habe ein Problem bei Incoming Calls über ISDN Karte.
Asterisk Version 10.8.0-rc1 auf Ubuntu 12.04 LTS

Die Karte wird korrekt vom System erkannt und ausgehende Calls funktionieren einwandfrei.

Bei eingehenden Calls wird dies auf der CLI signalisiert:

Code: Alles auswählen

== ISDN1#02: Incoming call '02216xxxxxx' -> '7532xxxx'
Allerdings wird nicht der Context aus der capi.conf aufgerufen:

Code: Alles auswählen

capi.conf

;
; CAPI config
;
;

; general section

[general]
nationalprefix=0        ; or for example "+49"
internationalprefix=00  ; or for example "+"
;subscriberprefix=+4969 ; prefix including area code (some lines need this)
rxgain=1.0       ;linear receive gain (1.0 = no change)
txgain=1.0       ;linear transmit gain (1.0 = no change)
language=de      ;set default language

; interface sections ...

[ISDN1]          ;this example interface gets name 'ISDN1' and may be any
                 ;name not starting with 'g' or 'contr'.
                 ;Use one interface section for each ISDN port!
;ntmode=yes      ;if the ISDN card operates in NT-mode, set this to 'yes'
isdnmode=msn     ;'MSN' (point-to-multipoint) or 'DID' (direct inward dial)
                 ;when using NT-mode, 'DID' should be set in any case
incomingmsn=*    ;allow incoming calls to this list of MSNs/DIDs, * = any
;defaultcid=123  ;set a default caller ID to that interface for dial-out,
                 ;this caller ID will be used when the dial option 'd' is set.
;controller=0    ;ISDN4BSD default
;controller=7    ;ISDN4BSD USB default
controller=1     ;CAPI controller number of this interface/port
group=1          ;dialout group
;prefix=0        ;set a prefix to the calling number on incoming calls
softdtmf=on      ;enable/disable software DTMF detection, recommended for AVM cards
relaxdtmf=on     ;in addition to softdtmf, you can use relaxed DTMF detection
faxdetect=off    ;enable faxdetection and redirection to EXTEN 'fax' for incoming and/or
                 ;outgoing calls. (default='off', possible values: 'incoming','outgoing','both')
faxdetecttime=0  ;Only detect faxes during the first 'n' seconds of the call.
                 ;(default '0' meaning for the whole duration of the call)
faxdestination=custom-fax,fax,1 ;Set custom context, exten and priority to jump to on faxdetect.
                 ;Default is "<current-context>,fax,1".
;accountcode=     ;PBX accountcode to use in CDRs
;amaflags=default;AMA flags for CDR ('default', 'omit', 'billing', or 'documentation')
context=isdn-in  ;context for incoming calls

Der entsprechende Context in der extensions.conf sieht folgendermaßen aus:

Code: Alles auswählen

;ISDN in

[isdn-in]
exten => _X.,1,NoOp
exten => _X.,n,Dial(SIP/80,120,tT)
Was mache ich falsch oder was habe ich vergessen.
Please help!

Danke und Grüße

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: Keine ISDN incoming Calls

Beitrag von rainer » Do 21. Feb 2013, 08:44

Hallo,

kannst du mal bitte in der extensions.conf unter [isdn-in] die 3x MSNs eintragen ... !!! ohne _ am Anfang und ohne . am Ende !!!

Beispiel:

Code: Alles auswählen

;ISDN in
[isdn-in]
exten => 75321234,1,NoOp( *** ISDN in auf die MSN 75321234 ***)
exten => 75321234,n,Dial(SIP/80,120,t)

exten => 75321235,1,NoOp( *** ISDN in auf die MSN 75321235 ***)
exten => 75321235,n,Dial(SIP/80,120,t)

exten => 75321236,1,NoOp( *** ISDN in auf die MSN 75321236 ***)
exten => 75321236,n,Dial(SIP/80,120,t)

Beispiel mit der same-Schreibweise

Code: Alles auswählen

;ISDN in
[isdn-in]
exten => 75321234,1,NoOp( *** ISDN in auf die MSN 75321234 ***)
          same => n,Dial(SIP/80,120,t)

exten => 75321235,1,NoOp( *** ISDN in auf die MSN 75321235 ***)
          same => n,Dial(SIP/80,120,t)

exten => 75321236,1,NoOp( *** ISDN in auf die MSN 75321236 ***)
          same => n,Dial(SIP/80,120,t)

Die Dial Option T solltest du nocheinmal überdenken ...
T = Allow the calling user to transfer the call
t = Allow the called user to transfer the call

Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

hkl
Anfänger
Beiträge: 2
Registriert: Di 19. Feb 2013, 08:52

Re: Keine ISDN incoming Calls

Beitrag von hkl » Do 21. Feb 2013, 09:18

Hallo Rainer,

das habe ich auch schon erfolglos getestet. :(

Wie gesagt zeigt die CLI einen eingehenden Call an, aber keinen Eintrag, dass in einen Context in der extensions gesprungen wird.
Ich habe mittlerweile auch mit Version 1.8 und 11 getestet, aber auch hier keinen Erfolg.

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: Keine ISDN incoming Calls

Beitrag von rainer » Do 21. Feb 2013, 09:41

Hallo,

kannst du das
bitte einmal durch

Code: Alles auswählen

NoOp ( *** ISDN-in *** )  
ersetzen.

NoOp ohne Textausgabe bringt nicht.

Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

Benutzeravatar
carlo_58
Anfänger
Beiträge: 3
Registriert: Mo 11. Mär 2013, 10:04
Wohnort: Geisenheim/Rheingau

Re: Keine ISDN incoming Calls

Beitrag von carlo_58 » Mo 11. Mär 2013, 10:21

Hallo hkl

Ich nehme doch an dass Du am Anfang Deiner extension.conf auch den context [isdn_in]
mit includes reingenommen hast!

wie z.B. hier (ich arbeite mit ael)
-------------------------------------
context home {
includes { sonderkz; IsdnAmt; IsdnQuer; ansagen; siptrunk; ivrmenu; voicemail;}
//
// SipTln 40-49
//
_4X => &sip-tln(${EXTEN});
//
// SipTln 50-59
//
_5X => &sip-tln(${EXTEN});
//
// MGCPtln 60-69
//
_6X => &mgcp-tln(${EXTEN});
}


//
// ***************************************************************** Amtsverkehr
//
// ***************************************************************** lcr anbindung
//
// ***************************************************************** Kommender Amtsverkehr
context IsdnAmt {

// includes {system_menu;}
--------------------------------

Hoffe dass es hilft

ciao
carlo
Anlagen: Hicom 125,Hipath 4000, Hicom 3500,Hic118,Asterisk 10.x, Asterisk 1.8 on Openwrt
Phone: GXP 2000, MGCP IP 15,3cxPhone on Clientpc's and Motorola Milestone2,Linksys PAP2T
tiny USB ISDN TA,S0/S2(Pri/Bri),
Centos,Ubuntu,Openwrt,DDWrt etc.

Antworten