eingehende Telefonate (SIP) funktionieren nicht

Konfigurationsdiskussionen bei Asterisk direkt

Moderatoren: rainer, Tim

Antworten
avalox
Anfänger
Beiträge: 4
Registriert: Mi 18. Dez 2013, 17:29

eingehende Telefonate (SIP) funktionieren nicht

Beitrag von avalox » Mi 18. Dez 2013, 17:39

Hallo zusammen,

ich bin absoluter Neuling was das Thema Asterisk angeht, habe heute aber mal angefangen zu "basteln".

Was bisher funktioniert (asterisk-11.6.1-1_centos6.x86_64) is folgendes:

- telefonieren intern zwischen 2 Telefonen
- rauswählen von beiden Telefonen

Was ich jedoch aktuell nicht hinbekomme sind eingehende Anrufe (immer besetzt).

Hier mal meine Configs:

sip.conf

Code: Alles auswählen

[general]
context=default
allowoverlap=no
udpbindaddr=0.0.0.0
tcpenable=yes
tcpbindaddr=0.0.0.0
srvlookup=yes
engine=asterisk
stunaddr=stun.easybell.de
externrefresh=60

disallow=all
allow=ulaw
allow=alaw
allow=g729 
allow=gsm 
qualify=no

register => 0049xxxxxxxxxxxx:pass@sip.easybell.de/0049xxxxxxxxxxxx  

[0049xxxxxxxxxxxx ]
type=peer
defaultuser=0049xxxxxxxxxxxx  
fromuser=0049xxxxxxxxxxxx 
username=0049xxxxxxxxxxxx 
secret=ctcp234znw
host=sip.easybell.de
fromdomain=sip.easybell.de
domain=sip.easybell.de
nat=yes
dtmfmode=auto
insecure=port,invite 

[easybell_de_in]
type=peer
host=sip.easybell.de
fromdomain=sip.easybell.de
domain=sip.easybell.de
dtmfmode=auto
context=incoming

[test-phones](!)
type=friend
context=default
secret=xxxxxxxx
host=dynamic
nat=no
qualify=yes
canreinvite=no
callgroup=1
pickupgroup=1
dtmfmode=auto
disallow=all
allow=g722

[43](test-phones)
callerid="Sebastian1" <43>
username=43
secret=test123

[44](test-phones)
callerid="Sebastian2" <44>
username=44
secret=test123

extensions.conf

Code: Alles auswählen

[general]
static=yes
writeprotect=no

[local]
exten => _XX,1,Dial(SIP/${EXTEN},55,TtrWw)

[outgoing]
exten => _0.,1,Dial(SIP/${EXTEN}@0049xxxxxxxxxxxx,45,hHw)

[incoming]
exten => 0049xxxxxxxxxxxx,1,Dial(SIP/43,30,r)

[default]
include => local
include => outgoing
include => incoming
Hoffe mir kann bei meinem Problem jemand helfen.

Am Ende sollen ganz einfach ALLE angeschlossenen Telefone klingen, wenn ein Anrufe rein kommt. Im Endeffekt fehlt mir nur noch das.

Gruß und danke
Sebastian

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 07:52

Hallo Sebastian,

für die STUN Einstellung gibt es in der Version 11 eine res_stun_monitor.conf Datei,
stunaddr in der sip.conf war mal in der Version 1.6 + ... war aber nicht sehr zuverlässig 8-)

res_stun_monitor.conf

Code: Alles auswählen

;
; Configuration file for the res_stun_monitor module
;
; The res_stun_monitor module sends STUN requests to a configured STUN server
; periodically.  If the monitor detects a change in the external ip or port
; provided by the STUN server an event is sent out internally within Asterisk
; to alert all listeners to that event of the change.

; The current default listeners for the netork change event include chan_sip
; and chan_iax.  Both of these channel drivers by default react to this event
; by renewing all outbound registrations.  This allows the endpoints Asterisk
; is registering with to become aware of the address change and know the new
; location.
;
[general]
;
; ---- STUN Server configuration ---
;  Setting the 'stunaddr' option to a valid address enables the stun monitor.
;
stunaddr = stun.easybell.de ; address of the stun server to query.
stunrefresh = 30     ; number of seconds between stun refreshes. default is 30
;
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 08:02

Hallo Sebastian,

ist dein Router zufällig eine FritzBox bzw. ein VoIP+Router-Gerät welches schon auf der public IP und auf den UDP Port 5060 hört?

Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

avalox
Anfänger
Beiträge: 4
Registriert: Mi 18. Dez 2013, 17:29

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von avalox » Do 19. Dez 2013, 12:52

Hallo ihr zwei,

res_stun_monitor.conf: hab ich geändert, danke für den Hinweis.

Bzgl. der Fritzbox. Ja, ist eine (Unitymedia). Hab sie sicherheitshalber auch mal mit nmap gescannt (auf UDP). Da ist nichts offen.

Ich finde komisch, dass besetzt ist, wenn ich mich vom Handy aus anrufe, aber nichts im log erscheint (trotz debug). Fahre ich astersik runter, schlägt der Anruf fehl. Es scheint also schon anzukommen.

Gruß Sebastian

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 15:28

Hi,

kannst du mal die CLI mit

Code: Alles auswählen

asterisk -vvvvvvvvvvvvvvvvvvvvvvvr
starten und den asterisk noch mal mit deinem Handy anrufen.
Da solltest du dann sehen, dass ein Anruf rein kommt.

Du kannst in der CLI auch prüfen, ob der asterisk wirklich bei easybell registriert ist ... mit

Code: Alles auswählen

sip show registry
Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

avalox
Anfänger
Beiträge: 4
Registriert: Mi 18. Dez 2013, 17:29

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von avalox » Do 19. Dez 2013, 15:40

Die Registrierung ist ok.

Ich hab jetzt mal folgendes gemacht

[incoming]
exten => 004921199540895,1,Answer()
exten => 004921199540895,2,Playback(hello-world)
exten => 004921199540895,4,Hangup()

das funktioniert. Ich rufe vom handy an, er spielt hello world ab und legt auf.

Nehme ich das wieder rein:

exten => 0049xxxxxxxxxxxx,1,Dial(SIP/43,30,r)

bzw. das:

exten => 0049xxxxxxxxxxxx,1,Dial(SIP/43)

ist wieder besetzt. In der Konsole kommt dann folgendes:

Code: Alles auswählen

Connected to Asterisk 11.6.1 currently running on officeschool (pid = 15791)
  == Using SIP RTP CoS mark 5
    -- Executing [0049xxxxxxxxxxxx@default:1] Dial("SIP/0049xxxxxxxxxxxx-00000000", "SIP/0049xxxxxxxxxxxx@0049xxxxxxxxxxxx,45,hHw") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/0049xxxxxxxxxxxx@0049xxxxxxxxxxxx
    -- Got SIP response 486 "Busy" back from 212.172.97.124:5060
    -- SIP/0049xxxxxxxxxxxx-00000001 is busy
  == Everyone is busy/congested at this time (1:1/0/0)
    -- Auto fallthrough, channel 'SIP/0049xxxxxxxxxxxx-00000000' status is 'BUSY'
Das Telefon (43) dahinter ist verfügbar und lässt sich auch intern anrufen. Auch kann man von dem Telefon rauswählen.

Danke für Deine Hilfe.

Gruß Sebastian

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 15:43

habe eben mal nach FritzBox sip port gegooglet und folgendes gefunden ...
Wichtig:
Die Freigabe von Port 5060 ist nicht möglich, da der Port für die Internettelefonie der FRITZ!Box reserviert ist.
siehe -> http://service.avm.de/support/de/SKB/FR ... -verwenden

Gruß
Rainer
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

avalox
Anfänger
Beiträge: 4
Registriert: Mi 18. Dez 2013, 17:29

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von avalox » Do 19. Dez 2013, 16:00

es geht jetzt.

hab einfach das hier komplett rausgeschmissen:

[easybell_de_in]
type=peer
host=sip.easybell.de
fromdomain=sip.easybell.de
domain=sip.easybell.de
dtmfmode=auto
context=incoming

und in der extensions alles unter default gepackt.

Danke für die Hilfe! :)

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 16:07

OK ... super ;-)
:D
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

Benutzeravatar
rainer
Profi
Beiträge: 183
Registriert: Di 17. Nov 2009, 20:18
Wohnort: Bonn
Kontaktdaten:

Re: eingehende Telefonate (SIP) funktionieren nicht

Beitrag von rainer » Do 19. Dez 2013, 16:27

und Gruß nach Düsseldorf ... da habe ich mal bei http://www.nsn.com in der R&D Abteilung gearbeitet.
Rainer Piper - Bonn - 0228 97167161 or SIP-URI: sip:7000@sip.soho-piper.de:5072
Software: kamailio 4.2.0 -> Asterisk 13.0.1 mit pjsip stack
Hardware: 2x QuadCore, 128GB ECC-RAM, 4x HDD Raid 10

Antworten